SQL Server - Function request not Supported

Description

The "Function request not supported" error is a SQL Server error that occurs when the SQL Server drivers are missing or the wrong SQL Server drivers are installed on the system.

Discussion

If the server does not have the correct drivers when querying a SQL Server database, the following error can occur:

Function requested is not supported

This error occurs when the required drivers for SQL Server are not installed. This often occurs when the drivers that are installed are older than the version of SQL Server that is running. For example, the Date type does not exist in any version of SQL Server prior to SQL Server 2008. If the ODBC drivers installed on a system are older than the version of SQL Server installed, an error can occur when doing a SQL query that includes Date fields. This issue manifests as a "Function request is not supported" error in a Grid or UX Component populated from a SQL Server database.

To correct the problem, the drivers for communicating with the SQL Server database need to be updated on the server running the Alpha Anywhere Application Server:

1. Download the latest ODBC drivers from Microsoft.

2. Install the drivers on the server running Alpha Anywhere.

3. Test your application.

It is recommended to install the latest ODBC drivers from Microsoft as they support current and most prior versions of Microsoft SQL Server. ODBC 13.1 supports connecting to Azure SQL Database, Azure SQL Data Warehouse, SQL Server 2016, SQL Server 2014, SQL Server 2012, SQL Server 2008 R2, SQL Server 2008, and SQL Server 2005.

Alternatively, you can search Microsoft's website for the recommended connection driver for the version of SQL Server that is being used.

See Also