Working with Workspaces

Description

Tables, sets, and workspaces are the primary structures for storing data in an Alpha Anywhere desktop applications. Your workspace files keep track of all of the tables, sets, toolbars, forms, and such, used for managing information. When you open an existing workspace, Alpha Anywhere displays the objects (tables, forms, etc.) that make up the workspace in the Control Panel. With Alpha Anywhere, you work with one workspace at a time.

Typically, you create different workspaces for unrelated uses. For example, if you keep track of information for your business and your home, you might create one workspace for your business and one for your home. Good design practices suggest that:

  • Each workspace have its own unique folder, unless

  • Two or more workspaces have common tables or interact, in which case the folders should be the same.

Creating a New Workspace 

To create a new workspace, either select New Workspace... from the Workspace & Tasks tab of the initial Select Workspace dialog or select File > New Workspace... from the Control Panel. The File dialog box appears where you can enter a name for the workspace you are creating. You can also create a workspace from a . , .XLS (Microsoft Excel spreadsheet), or .MDB (Microsoft Access workspace) file.

  1. In the Control Panel select File > Open Workspace... to display the Open Workspace dialog.

  2. Navigate to the directory containing the file.

  3. In the Files of type list select either:

    • .DBF (Alpha Anywhere table)

    • .XLS (Excel spreadsheet)

    • .MDB (Access workspace)

  4. Click Open to display the Select Tables/Views to Import dialog.

  5. Place checkmarks next to the tables to import and click OK > Close.

If the data is in an Microsoft Excel Spreadsheet or Microsoft Access workspace, Alpha Anywhere import it into a .DBF file (Alpha Anywhere table). Finally, Alpha Anywhere will create a workspace (.ADB) file to contain the table.

Opening an Existing Workspace 

To open an existing workspace:

  • To browse for the workspace, select More Workspaces... from the Alpha Anywhere screen

  • If the desired workspace appears in the recently opened workspace list, select the name and click OK.

  • If the Alpha Anywhere screen is not available, select File > Open Workspace... .

Limitations

Desktop applications only. Not available in Community Edition.

See Also